Полезная информация Гайд по установке/обновлению сборки

Discussion in 'Вопросы и ответы' started by Zim777, Sep 16, 2018.

  1. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3

    Гайд актуализирован для версии Rimworld 1.0
    Внимание! На текущий момент сборка HSK (ветка stable) работает только с RimWorld 1.0 версии 1.0.2282 1.0.2408 или 1.0.2559, последняя доступна для установки в Steam ( Библиотека - Свойства RimWorld - Бета-версии - RimWorld 1.0 - OK )

    Внимание!!! Ветка development на текущий момент является первичным тестовым вариантом для RimWorld 1.1. Поэтому она на текущий момент на английском языке, а также имеют огромное кол-во багов. Обновляйтесь только в том случае, если вы готовы помогать с тестом и поиском багов.




    Установка/обновление сборки

    1. Удаляем саму игру и пользовательские файлы в AppData. Это нужно только в случае, если предыдущая установка у Вас прошла неудачно и Вы получили в игре серьёзные ошибки (сломанный интерфейс, игра не загружается и т.п.), либо просто хотите чистую установку.
      • Удаляем папку с установленной игрой:
        Для пользователей Steam:
        • открываем Steam --> Библиотека --> правой кнопкой мыши по Rimworld --> Удалить
        • далее идём по пути Steam\steamapps\common и удаляем папку Rimworld, которую не удалил Steam
        Для пиратов:
        • удаляем папку с игрой

      • Очищаем пользовательскую папку в AppData. Максимально простой способ - скачиваем архив из ресурсов нашего форума, запускаем файл из архива и следуем инструкции на экране. Либо ручками:
        • копируем путь %UserProfile%\AppData\LocalLow
        • вставляем его в проводник Windows
          [​IMG]
        • нажимаем ENTER и попадаем в нужную нам папку
        • ищем и удаляем папку Ludeon Studios целиком

    2. Устанавливаем игру в удобное для Вас место, запускаем игру и выходим из неё, когда увидели меню игры. Для чего это было сделано? Все просто - игра создает необходимые папки в папке Вашего пользователя, где впоследствии будут храниться сохранения и настройки, и куда также будет добавлена часть необходимых файлов от HSK.

    3. Скачиваем наш ланчер и устанавливаем/обновляем им нашу сборку. На данный момент проще всего это сделать именно нашим ланчером, который умеет ставить сборку для RimWorld 1.0. Он сам скачает нужные файлы с гитхаба и поместит их в нужные места на компьютере, а так же предупредит Вас, если Вы пытаетесь установить сборку на неверную версию игры. Вам не придётся ничего дополнительно копировать, всё будет сделано правильно и ничего не забудется. Этот способ крайне рекомендуется всем пользователям! Либо можно устанавливать сборку вручную, не забывая следовать каждой рекомендации.
      • Скачиваем сборку проекта Hardcore-SK с github версию Stable (для RimWorld 1.0). В скачанном Вами архиве помимо папки Mods будут присутствовать и другие файлы и папки. Не обращайте на них внимания - просто игнорируйте их - это служебные файлы и папки для команды проекта. Вам важны лишь папка Mods и файл ModsConfig.xml из архива.
        Важно! Убедитесь, что у вас стоит именно RimWorld 1.0
        Копируем содержимое папки Mods архива в папку Mods Вашей игры с заменой! всех предложенных файлов. Убеждаемся, что не делаем папку Mods/Mods/.
      • Копируем файл ModsConfig.xml из архива в пользовательскую папку по пути %UserProfile%\AppData\LocalLow\Ludeon Studios\RimWorld by Ludeon Studios\Config с заменой!
    Просьба, ко всем, у кого что-то - обратите внимание:
    1. На состояние вашего ПК и ОС, а именно: отсутствие вирусов, отсутствие двух и более антивирусных программ.
    2. Установленный Microsoft .NET Framework 4.8. У некоторых бывают проблемы с установкой игры или ланчера - часто спасает обновление Microsoft .NET Framework до версии 4.7
      https://www.microsoft.com/ru-ru/download/details.aspx?id=55167
      А после до Microsoft .NET Framework версии 4.8
      https://go.microsoft.com/fwlink/?linkid=2088631
      Если у Вас установлен Windows 7 - то перед установкой Microsoft .NET Framework 4.7 придется установить несколько обновлений: Windows6.1-KB3177467-x64, а потом windows6.1-kb4457144-x64
      https://www.microsoft.com/ru-ru/download/details.aspx?id=53863
      http://download.windowsupdate.com/d..._5ca467d42deadc2b2f4010c4a26b4a6903790dd5.msu
    3. На параметры вашего ПК и ОС - ОС должна быть Win 7\8\8.1\10 системы обязательно х64, оперативной памяти минимум 4GB (желательно 8GB). CPU - крайне желательно с высокопроизводительными ядрами.
    4. Наличие файла подкачки - игра часто использует файл подкачки. Если у Вас ОЗУ составляет 8GB или меньше, то рекомендуется файл подкачки установить 8-12GB.
      Это же относится и к тем, у кого большие объемы ОЗУ, 8GB файла подкачки - это также минимально рекомендуемый размер.
    Если у Вас что-то не вышло - внимательно прочитайте гайд снова, и подумайте, а не ошиблись ли Вы где-то? Самые обычные ошибки:
    • установка сборки для релиза 1.1 - HSK на данный момент работает только с RimWorld 1.0
    • отсутствие первого запуска чистой игры без модов перед установкой HSK;
    • установка новой сборки без очистки предыдущих папок;
    • отсутствие антивирусной программы и наличие огромного кол-ва самих вирусов, наличие двух и более антивирусных программ, отсутствие нужных обновлений ОС и подобные мелкие или неявные недочеты.
    Если у Вас все равно что-то не выходит - не забудьте написать параметры вашего ПК, а также все-таки подумайте, а точно ли Вы следовали гайду. Так нам будет проще отвечать на ваш конкретный случай.

    Гайд составлен при поддержке @Dzeniba и дружного сообщества Discord
     
    Last edited: May 25, 2020
    • Круто! Круто! x 6
    • Информативно! Информативно! x 4
    • Мне нравится! Мне нравится! x 1
    • List
  2. Empyky

    Empyky Муха-мутант

    Messages:
    33
    Likes Received:
    1
    Ratings:
    +8 / 0
    доброго времени суток. есть информация когда выйдет хардкор под 1.1 версию и нужно ли будет покупать длс роялити? можно ли будет запустить БЕЗ этого длс или он обязателен?
     
  3. Frazer

    Frazer Москит-мутант

    Messages:
    8
    Likes Received:
    0
    Ratings:
    +2 / 0
    Версия RimWorld v1.0.2408
    Версия HSKLauncher 1.6
    Моды стандартные ХСК
    Установил, все запускается, карта создается. В целом все что в начальном меню работает.
    Но в самой игре на карте нет менюшек внизу, ЛКМ на работает. Выбрать ничто не могу.
     
  4. Jambo

    Jambo Блоха

    Messages:
    1
    Likes Received:
    0
    Ratings:
    +0 / 0
    Здравствуйте! Подскажите, у меня версия игры 1.1 пиратка, можно ли как то откатить до 1.0? или где скачать? Сам не чего не смог найти.
     
  5. Dallahan

    Dallahan Блоха

    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    Здравствуйте! хотел как то обновить сборку сделал как в гайде при установки обновления лаунчер пишет что HSK 1.0 не подходит для установки на 1.1. Скачивал HSK 1.6 пробовал даже устанавливать в другое место все равно выдает такую вот информацию.
    [​IMG]
     
  6. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    Но вам же четко и ясно говорится, что вам нужен римворлд версии 1,0, а вы подсовываете 1,1
     
  7. Dallahan

    Dallahan Блоха

    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    у меня стим версия как тогда вернуть 1.0?
     
  8. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    В самом верху гайда написано
     
  9. Dallahan

    Dallahan Блоха

    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    спасибо не заметил
     
  10. mor

    mor Блоха

    Messages:
    1
    Likes Received:
    0
    Ratings:
    +0 / 0
     
  11. vinonarider

    vinonarider Блоха

    Messages:
    4
    Likes Received:
    0
    Ratings:
    +0 / 0
    Обновление не удалось, на после 15 метров загрузки. что делать? уже раза 3 пытался сделать.
    Паходу какой то сервер лагает у вас выбрал не стабле и паставилось...
     
    Last edited: May 15, 2020
  12. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    Лагает у вас связь с гитхабом. У нас нет серверов. Сам ХСК лежит на GitHub.
    Так что если у вас проблемы со связью с GitHub - это не наша вина.
     
  13. vinonarider

    vinonarider Блоха

    Messages:
    4
    Likes Received:
    0
    Ratings:
    +0 / 0
    Я загрузил Development версию все норм, с гит негрузилось через лаунчер, а вот на прямую с портала загрузилась, так что проблем у меня нету с гитхабом. Проблемы с лаунчером.
     
  14. SeregaBess

    SeregaBess Блоха

    Messages:
    1
    Likes Received:
    0
    Ratings:
    +0 / 0
    При запуске игры в последней загрузке ресурсов (Resolving Devs: 216/216 HelpDef), всё зависает пробовал через лаунчер загружать моды и вручную, с авто запуском только core и включал самостоятельно все равно зависает, без понятия из за чего это.
     
    Last edited: Jun 4, 2020
  15. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    во время загрузки игра имеет 3-4 момента, когда кажется что игра зависла.
    Не трогайте ее, дайте ей загрузится. На некоторых маломощных калькулятаров это может занять до 15 минут.
    Совет - ставьте в меня настроек Рима перед установкой самой хск - играть в фоне.
    После этого ставите ХСК, запускаете и как только начинает идти загрузка - сворачивайте игру, как только заиграет музыка из меню - игра загрузилась - разворачиваете и играете.
     
  16. jaymz

    jaymz Москит-мутант

    Messages:
    13
    Likes Received:
    0
    Ratings:
    +1 / 0
    день добрый! скажите пж можно ли обновлять сборку через хск лончер и остаться со старыми сохранками? стоит версия от 2020.03.19. будет ли все работать или нужен новый мир?
     
  17. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    Если вы обновляете с 1,0 на 1,1 - нет
    Если вы обновляете 1,0 на более новую 1,0 - 50на50
     
  18. jaymz

    jaymz Москит-мутант

    Messages:
    13
    Likes Received:
    0
    Ratings:
    +1 / 0
    спасибо, обновил, подтянул список модов, полет нормальный!)
    правда за 7 лет колонии ни одного терминатора не было, да и механоиды не посещают. в чем может быть проблема?
     
  19. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    В низкой стоимости колонии и низком уровне сложности.
    Играйте на кошмаре или пекле и с хск-шными рассказчиками
     
  20. UnHappyKin8

    UnHappyKin8 Блоха

    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    А можно поинтересоваться, ветка development на какую именно версию 1.1? У меня пиратская версия 1.1.2652. Может нужна версия поменьше? Если да, то подскажите на какую. Заранее спасибо
     
  21. Zim777

    Zim777

    Messages:
    275
    Likes Received:
    23
    Ratings:
    +135 / 3
    рекомендуется использовать 2647. Но лично у меня нет проблем с самым последним билдом
    https://cdn.discordapp.com/attachments/365855836637233152/724603745635270656/Screenshot_22.png